пятница, 9 декабря 2011 г.

Настройка Mikrotik RouterBOARD 493G + Mikrotik RouterBOARD R52Hn MiniPCI + Ubiquiti RocketDish 5G: 5GHz строительство канала 20 км 200 mbps full duplex

Итак имеем 2 RouterBOARD 493G — отличные маршрутизаторы 9 гигабитных портов (если запитывать через PoE то 8x1000 1x100), 3 pci слота. В pci Мы как раз и вставим карту RouterBOARD R52Hn MiniPCI — которая хорошо себя зарекомендовала в работе как в 2.4 диапазоне так и в 5ггц. Для такого расстояния и требуемой пропускной способности канала нужна серьёзная антенна. Я выбрал RocketDish 5G: 5GHz довольно мощное блюдце не смотря на то что всего 60 см. Итак перейдем к настройке.
База. Настройки довольно тривиальна для mikrotik.Я об этом уже писал здесь
1. Подключаум Mikritik R52Hn к Mikritik 493G
2. Подключаемся через Winbox по MAC адрессу
3. Создаем интерфейс Bridge1.
4. Закидываем туда интерфесы Wlan1 и необходимые EthXX
5. Создаем managment Vlan.


6. Настраиваем IP адреса и шлюз.

7. Настраиваем Wlan interface.



7 Пункт распишу более подробно.
Mode bridge
Band 5Ghz-onle-N
Chanel Width 20/40Mhz HT Adove
Frequebcy Ваша частота из диапазон 5200-5800
SSID — имя базовой станции. По этому имени клиент ищет свою БС
Wireless Protocol — nv2 — В последней прошивке как раз для этого протокола увеличили пропускную способность на 15%
Frequebcy mode — superchanel
Остальные настройки можно оставить по умолчанию.

Настройка клиента идентична за исключением пункта 7
Mode - Station WDS

На этом настройка законченна. Теперь необходимо хорошо отюстировать антенны, благо на Ubiquiti RocketDish стоят крепления которые это позволяют. У меня получился уровень сигнала -55dbi что в 40 mhz позволила гонять трафик реально до 200 mbps в дуплексе (хотя это speedtest. Реального upload в таком объеме ещё небыло). Если есть вопросы по настройке mikrotik пишите.
В следуюшей статье я напишу о том как привязать к Mikrotik RouterBOARD 493G 2 карточки RouterBOARD R52Hn MiniPCI и сделать автоматическое переключение между каналами (резервирование каналов на подобии этого)

14 комментариев:

  1. Доброго здоровья. А в командной строке не поможкте с настройкой такой связки RouterBoard 433UAH + R52Hn? Признаюсь, я не IT-специалист и железо попало в руки по случаю. Отдавать жалко, хотелось бы понять и настроить.
    Наши параметры интернет-настоек, выданные провайдером


    IP-адрес: 172.18.2.242,
    Маска: 255.255.0.0 (или /16),
    Шлюз: 172.18.1.1.

    DNS 194.190.5.24
    8.8.8.8

    Логин: mylogin
    Пароль: mypass


    Настроим порт в интернет ether3

    /ip address add interface="ether3" address="172.18.2.242/16"
    /ip route add dst-address="172.0.0.0/8" gateway="172.18.1.1"
    /ip dns set servers=194.190.5.24,8.8.8.8 allow-remote-requests=yes


    Теперь создаем второй интерфейс — PPTP-соединение:

    /interface pptp-client add name="MyPPTP" connect-to="172.0.0.1" user="mylogin" password="mypass" add-default-route="yes"
    /interface enable "MyPPTP"

    И, наконец, настраиваем NAT на обоих интерфейсах:

    /ip firewall nat add out-interface="ether3" chain="srcnat" action="masquerade"
    /ip firewall nat add out-interface="MyPPTP" chain="srcnat" action="masquerade"

    Настраиваем внутренний интерфейс ether2:

    /ip address add interface="ether2" address="192.168.100.1/24"

    Объединяем порты ether1 и ether2, назначив ether2 мастер-портом:

    /interface ethernet set "ether1" master-port="ether2"


    Задаем пул IP-адресов:

    /ip pool add name="Pool" ranges="192.168.100.2-192.168.100.254"

    Затем создаем экземпляр DHCP-сервера:


    /ip dhcp-server add name="DHCP" interface="ether2" address-pool="Pool" disabled="no"

    Определяем адреса шлюза по умолчанию и сервера DNS, которые будут использоваться в нашей сети:

    /ip dhcp-server network add address="192.168.100.0/24" gateway="192.168.100.1" dns-server="192.168.100.1" domain="home"



    И в итоге у меня интернет не пашет. Как в командной строке к этой связке привязать беспроводную карту, я тоже не понимаю.

    ОтветитьУдалить
    Ответы
    1. PPTP соединение проходит пормально?
      ошибок в логах нет?
      по моему должно быть /interface pptp-client add name="MyPPTP" connect-to="172.18.1.1" user="mylogin" password="mypass" add-default-route="yes

      Удалить
    2. Вы правы, соединение с интернетом появилось. Спасибо огроменное!!! Теперь бы мне еще и Wi-Fi наладить каким-то образом, потом уж с файерволом начну разбираться.
      В настройках беспроводки выставил режим "ap bridge", 2GHz B/G/N , частота 2452MHz, имя wlan1 , протокол nstreme и поставил галочку enabled. Комп сеть Mikrotik видит, но подключится не может. Я умом-то понимаю, что надо беспроводку привязать к той же локалке, что и ether2, но вот как это сделать, не соображу пока. Может подскажете?

      Удалить
  2. обьеденить интерфейсы легко
    создайт6е интерфейс bridge и закинте туда необходимые интерфейсы. и еще не знаю как в 2 мгц а в 5 в режиме nstreem можно только 2 микротика соеденить.

    ОтветитьУдалить
    Ответы
    1. Спасибо, я убрал режим nstreme. Соудинения по Wi-Fi настроить не смог. Где-то провал.
      А вот внутренний интерфейс для WLAN1 мне нужно создавать? Типа того, что я делал с ether2
      /ip address add interface="ether2" address="192.168.100.1/24"
      Или адрес будет из этого пула выдан?

      Удалить
  3. /ip address add interface="bridge1" address="192.168.100.1/24"

    а в интерфейс bridge1 закинуть wlan1 и eth1
    как то так

    ОтветитьУдалить
  4. Спасибо, натолкнули на путь истинный. Или почти истинный (всё-таки я не айтишник, ошибок могу напороть кучу). Ip-адрес 192.168.100.1/24 я оставил за ether2, но создал bridge1 в webfig и закинул туда все три моих интерфейса, что смотрят в локалку, в том числе и wlan1. dhcp-server привязал к bridge1 вместо ether3 и УРЯ! Всё заработало. В том числе и WiFi.
    В любом случае вам огроменное спасибо, без Вас мне бы никак не справится. Сейчас начну постепенно разбираться с файерволом. Если вы позволите, я могу обращаться к Вам с вопросами?

    ОтветитьУдалить
  5. Ответы
    1. Джамал подскажи да брат ,как прошить карточка на микротик r 52hn?

      Удалить
  6. обновись до последней версии Router OS и будет тебе счастье.
    http://itsettings.blogspot.com/2012/02/router-os-513-512-56.html

    ОтветитьУдалить
  7. Анонимный26 июля 2012 г., 9:04

    Здравствуйте. Подскажите пожалуйста для новичка. С ребятами прикупили базовую станцию http://beecomp.ru/catalog/products/omni_on_the_basis_of_RB_411AH/the_base_station_rb411ahpohn_amo_2g13/ в комплекте вроде все есть. Собрал это все дело, подключил к компьютеру, теперь не могу найти где находится управление, то есть, какой нибудь web интерфейс или еще что нибудь для управления всем этим делом.

    С уважением.

    ОтветитьУдалить
  8. 192.168.88.1 там web интерфейс
    или winbix качни https://wirelessconnect.eu/articles/winbox_download
    и он сам найдет подключенный микротик

    ОтветитьУдалить
  9. Скажите, на RouterBOARD 493G + R52Hn на 2GHz не могу получить скорость больше 20Mbps (Win10 закачка 2MB/c) что с планшетом что с ноутбуком. В чем может быть причина? Такое впечатление что где-то установлено ограничение скорости.

    ОтветитьУдалить
  10. От связки RB493G + R52Hn не могу выжать скорость выше 20-25Mbps вместо ожидаемых 300Mbps. И на планшет SM-T805 ни на ноутбук Fujitsu LIFEBOOK T580 скорость одинаковая. Скорость мерил внутри квартиры, она не зависит от расстояния. Пробовал режим "ap bridge", 2GHz B/G/N и 5 GHz А/N. Подскажите пожалуйста в чём может быть причина?

    ОтветитьУдалить