четверг, 16 августа 2012 г.

Настройка Nanostation M2 В режиме точка-точка (база - клиент)

Добрый вечер.
Сегодня мне в руки попала интересная точка доступа от компании UBNT - Nanostation M2. В компактном формате довольно мощный Wi-Fi девайс, который следует философии UBNT - все в одном поставил и забыл. По размерам и характеристикам NanoStation M2 - это младший брат уже знакомого нам NanoBridge. Тестировать его в режиме точка-точка я буду ближе к концу недели на расстоянии 1.2 км и результаты сообщу отдельным постом. А пока я расскажу про настройку этих точек в режиме База - Клиент.

Настройка клиента.
1 Подготовка.
1.1 Подключить NanoStation через PoE согласно инструкции.
1.2  Сбросить NanoStation  на параметры по умолчанию. Для этого возле Ethernet порта имеется специальная кнопка, которую, необходимо нажать и держать, пока не моргнут все лампочки.
(Если ваш NanoStation новый этот шаг можно пропустить)
1.3  Задать на вашем ПК IP адрес из сети 192.168.1.0-192.168.1.254 маска 255.255.255.0. Любой кроме 192.168.1.20.
2 Обновление прошивки.
2.1 Заходим браузером по адресу http://192.168.1.20.
2.2 Вводим логин ubnt и пароль ubnt и попадаем на главную страницу.
2.3 Переходим на вкладку System
2.4 Нажимаем кнопку Update и обновляем прошивку до последней версии на данный момент это 5.5. Последнюю версию можно скачать на сайте ubnt.com




3 Настройка роутера
3.1 Заходим браузером по адресу http://192.168.1.20.
3.2 Вводим логин ubnt и пароль ubnt и попадаем на главную страницу.
3.3 Переходим на вкладку Wireless и задаем следующие параметры:

3.3.1 Wireless mode - station
3.3.2 WDS - enable
3.3.3 SSID - Имя базовой станции.
3.3.4 Country code - complince test
3.3.5 Frequency list MHz - enable. там же нажимаем Edit и выбираем необходимые частоты на которых мы и будем работать.Я выбираю все доступные частоты так как в случае появления помех достаточно будет только сменить частоту на базовой станции и клиент сам на нее переключиться. Но при очень большом диапазоне выбранных частот клиент будет довольно продолжительное время искать базовую станцию перебирая все отмеченные частоты.

3.4 Нажимаем Change - Aplay.
3.5 Переходим на вкладку Networks и задаем следующие параметры:

3.5.1 IP адрес (можно оставить и адрес по умолчанию, но в случае если девайсов в сети много и в процессе эксплуатации понадобится сбросить один из них в default возникнет конфликт IP адресов.
3.5.2 Маска подсети
3.5.3 Основной шлюз
3.5.4 Основной и резервный ДНС сервер
3.5.5 Network mode - Bridge.
3.5.6 Нажимаем Change - Test -Aplay.
3.6 Переходим на вкладку System
3.6.1 Меняем пароль на вход в администрирование Nanostation M2.
3.6.2 Меняем имя девайса.
3.6.3 Нажимаем Change - Test -Aplay.

3.6.4 Перелогиниваемся заходим на вкладку System и нажимаем Backup configuration.
На этом настройка клиентской части закончена.
4 Настройка базовой части.
4.1 Повторить шаги 1 - 3.
4.1 Заходим браузером по адресу http://192.168.1.20.
4.2 Вводим логин ubnt и пароль ubnt и попадаем на главную страницу.

4.3 Переходим на вкладку Wireless и задаем следующие параметры:

4.3.1 Wireless mode - Access Point
4.3.2 WDS - enable

4.3.3 SSID - Имя базовой станции.
4.3.4 Country code - complince test
4.3.5 Frequency list MHz - частота на которой будет работать Nanostation.

4.4 Нажимаем Change - Aplay.
4.5 Переходим на вкладку Networks и задаем следующие параметры:
4.5.1 IP адрес (можно оставить и адрес по умолчанию, но в случае если девайсов в сети много и в процессе эксплуатации понадобится сбросить один из них в default возникнет конфликт IP адресов.
4.5.2 Маска подсети
4.5.3 Основной шлюз
4.5.4 Основной и резервный ДНС сервер
4.5.5 Network mode - Bridge.
4.5.6 Нажимаем Change - Test -Aplay.
4.6 Переходим на вкладку System
4.6.1 Меняем пароль на вход в администрирование Nanostation M2.
4.6.2 Меняем имя девайса.

4.6.3 Нажимаем Change - Test -Aplay.
4.6.4 Перелогиниваемся заходим на вкладку System и нажимаем Backup configuration.
На этом настройка базовой станции закончена.
Если вы направите 2 NanoStation M2 друг на друга то в течении 10-15 секунд клиент подключится к базе. Это будет видно по индикации на задней панели и через WEB интерфейс на вкладке Main.

вторник, 14 августа 2012 г.

LDAP авторизация Windows 7 + SAMBA

Про то как настроить данную связку статей написано много.
но есть пара нюансов при использовании этой связки.
Во первых: Windows 7 не принимает логин длиннее 20 символов выдавая ошибку
local session manager failed to logon system call is too  small

Во вторых: Чтобы этя связка работала необходимо немного пропатчить реестр
либо вручную задать данные значения для ключей.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
"DNSNameResolutionRequired"=dword:00000000
"DomainCompatibilityMode"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\System\DNSClient]
"NV PrimaryDnsSuffix"="UA-SIM-01"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters]
"NV Domain"="UA-SIM-01"

Либо как сделал я сохранить данный код в текстовый файл и использовать импорт.
Удачи всем!



четверг, 12 июля 2012 г.

SUSE Studio класная игрушка для линуксовода

При поиске инструментов для создания собственного дистрибутива Linux наткнулся на очень интересный ресурс http://susestudio.com.
За который хочется поблагодарить его создателей. к них получился легкий удобный и быстрый сайт где с режиме онлайн за 5 минут можно создать свой собственный дистрибутив. Выбор настроек очень богат и порывает 90% всех потребностей.
Выбор ядра, репозиториев, пакетов, носителей просто огромен. Но главное всеже удобный интерфейс и скорость работы и возможность настроить софт который будет установлен. Никогда не думал что  от идеи собственного дистрибутива до его запуска может пройти менее 20 минут!
Поэтому если вам нужен специфический LIVE CD с линруксом или димтрибутив с определенным набором пакетов не теряйте времени http://susestudio.com. решит ваши проблемы за 20 минут.

понедельник, 18 июня 2012 г.

Позор компании микротик RB750/751

Давно и плодотворно использую продукцию компании микротик.
Установлены десятки rb711 rb411 rb413 rb493. вся продукция зарекомендовала себя с лучшей стороны. Надежные простые недорогие карточки. По этому когда возникла необходимость создать Wi-Fi зону на профессиональном оборудовании выбор пал на rb751. За 689 грн.шт мне обещали супер мощную Wi-Fi точку с многими интересными возможностями, стабильной работой и полным контролем. В итоге мы имеем:
1. Крайне глючное железо.( постоянные обрывы связи отказы DHCP сервера, произвольные перезагрузки, просто перестает пропускать трафик, и т.д.)
2. Полностью нерабочий STP. От кольца пришлось полностью отказаться.
3. Очень медленная работа. При любом изменении топологии эти роутеры раздупляются не меньше 15 минут. Иногда вообще не раздупляются и приходится перегружать всю сеть.
4. Крайне слабый уровень сигнала. Территорию которую можно было накрыть с помощью 5-7 PowerAP N с мощностью 800  мвт. Еле накрывают 10! микротиков мощностью 1 вт. И то чтобы усилить сигнал приходится использовать внешние антенны D link 8 dbi по 160 грн шт + 120 пигтейл.
5. -30% скорости при пропуске трафика через роутер. И это всего лишь nat + pppoe и то до 10 мб\с не доходит. И без торрентов.
6. Еще 1 очень интересный глюк наблюдается именно с этой железякой. Периодически просто перестает пропускать IP траффик. пинги не проходят но mac telnet работает. Помогает только перезагрузка.
При цене PowerAP N в 1000  гривен разница в качестве заметна сразу.
в Итоге после 2 месяцев настроек, допиливания, перепрошивок сети нормально так и не заработала. Wi-Fi Покрытие очень слабое, Клиент недоволен, а главное пострадала моя репутация. Я до сих пор не могу понять как можно выпускать в свет такой сырой и глючный продукт который по количеству глюков даст фору самому дешевому китайцу!
Как можно сделать роутер с полу рабочим DHCP сервером который не может работать даже неделю без перезапуска ( а то и полной перенастройки.
При всем моем уважении к компании микротик и их продукции RB751 - это не роутер это глючное говно.

пятница, 6 апреля 2012 г.

WinBox error (port 20561) timed out!

Неприятная ошибка вылезла в момент настройки RB493G. В интернете немного информации по этой ошибке и все советы можно уместить в одном абзаце.

  1. Подключатся по MAC адресe а не по IP.
  2. Отключить firewall.
  3. Переустановить winbox.
  4. Попробовать дернуть роутер через netinstal.
Как и ожидалось ни один из советов лично мне не помог. Зная качество компании Mikrotik  решил еще раз перепроверить все настройки. Вся загвоздка была в 2 галочках в настройках подключения по локальной сети.
как только я включил "Клиент для сетей Майкрософт" , и "Службу доступа к файлам и принтерам Майкрософт" Все заработало без нареканий. 
Не зная чей это косяк - Микротика или мелкомягких но у меня есть стойкая уверенность в том что эти 2 службы никак не должны влиять на этот уровень OSI. Надеюсь что эту проблему в ближайшее время устранят.
Коллеги будьте внимательны и все получится

пятница, 30 марта 2012 г.

Mikrotik RouterBOARD POE-CON-HP

Многие, кто работал с оборудованием Mikritok и Ubiquiti обращали внимание что питание на эти устройства подается через бп PoE 24V. И очень сожалели что 95% современных свитчей с PoE выдают на порту 48V. И хотя эти компании в своих анонсах еще зимой обешали выпустить свитчи собственного производства с PoE подходящего вольтажа - воз и ныне там. Теперь же компания Mikrotik обещает выпустить конвертер с PoE на PoE только нужного вольтажа. С одной сторону это конечно удобно. Наконец появится возможность перезагрузить или выключить устройство над которым утерян контроль. Но с другой стороны - переплачивать за свитч с PoE а потом еще и конвертера покупать. Двойная переплата выходит. Да и если строите серьезную сеть то желательно не разводить зоопарк и использовать оборудование 1 поставщика. Но в любом случае ждем с нетерпением так как реальный девайс в сели даже если он неказись и дорог лечше любого красивого анонса.



Name RouterBOARD POE-CON-HP
Ethernet Two Ethernet ports with grounding pins
(Works also with Gigabit devices, but only at 10/100 speed)
Dimensions 107x66x24mm
Power Input 42-57V (Passive, Telecom, 802.3af and 802.3at PoE plus supported)
Power Output 24V 1A
Output pins 4,5 “+”; 7,8 “-”


Mikrotik серия маршрутизаторов RB2011L

RouterBoard2011 это серия недорогих маршрутизаторов, для установки внутри помещения. Роутеры, представленные в этой серии, полностью покрывают все потребности для создания небольшой сети. RouterOS L4 на борту дает богатый функционал и легкость управления и конфигурации.
В серию входит 5 маршрутизаторов:

RB2011L

RB2011L-IN (настольный вариант)

RB2011L-RM (для монтажа в стойку),
RB2011LS (добавлен SFP порт ) and
RB2011LS-IN (добавлен SFP порт настольный вариант ). 

CPU Atheros AR9344 600MHz
Memory 64MB DDR SDRAM onboard memory
Ethernet Five 10/100 Mbit Fast Ethernet ports with Auto-MDI/X
Five 10/100/1000 Mbit Gigabit Ethernet ports with Auto-MDI/X
Expansion RB2011LS model: SFP port
Extras Reset button, Reset jumper
LEDs Power, User, Ethernet activity
Power options Jack 8-28V DC; PoE:  8-28V DC on Ether1 (Non 802.3af).
Dimensions 214 mm x 86 mm, Weight: 146g
Power consumption 8W max
Operating System MikroTik RouterOS, L4  license
Package includes RB2011, indoor case and power supply

Feature / Model     2011L     2011L-IN    2011L-RM    2011LS   2011LS-IN
Enclosure                -              Desktop       Rackmount        -            Desktop
SFP port                 -                -                  -                     Yes           Yes
Serial port               -                -                  -                      -                -
USB                       -                -                  -                      -                -
Wireless                  -                -                 -                      -                 -



Mikrotik RouterBoard 1200

RB1200 - Новый гигабитный роутер в семействе роутеров микротик в формате U1. На борту имеется 10 гигабитных портов 5 из которых могут быть объединены в 1 логический. Так же имеется COM Порт  и SODIMM слот в который можно вставить 512 мб оперативной памяти.







Характеристики:
CPU PowerPC PPC460GT
Memory SODIMM DDR Slot, 512MB RAM
Boot loader RouterBOOT, 1Mbit Flash chip
Ethernet Ten 10/100/1000 Mbit/s Gigabit Ethernet with Auto-MDI/X
miniPCI none
Storage Onboard NAND chip
Serial port One DB9 RS232C asynchronous serial port
Extras Reset switch, Beeper
Power options IEC C14 standard connector 110/220V
Fan default none, header for optional fan available
Dimensions 1U case: 44 x 176 x 442 mm, 1200g. Board only: 365g
Operating System MikroTik RouterOS, Level 6 license

Mikrotik Metal 5SHPn

Metal 5SHPn - Новый крепкий, влагонепроницаемый, супермощный радиодевайс от
компании Mikotik. Про мощность я не преувеличиваю 1.3W мощность Wi-Fi карточки в этом девайсе. Металлический корпус позволяет использовать данный девайс на улице не опасаясь погодных условий.




Вот подробные ттх на этот RouterBOARD.

CPU Atheros AR7241 400MHz network processor
Memory 64MB DDR SDRAM onboard memory
Ethernet One 10/100 Mbit/s Fast Ethernet port with Auto-MDI/X, L2
Wireless Wireless Built-in 5GHz 802.11a/n 1x1 MIMO, 
N-male connector, Up to 1.3W output power
Extras Reset switch, Beeper, Voltage monitor, Temperature moni
LEDs 5    wireless    signal    LEDs,    ethernet    activity    LED    (confgurabl
Power options Passive 8-30V PoE only. 16KV ESD protection on RF por
Consumption Up to ~0,5A at 24V (11.5W)
Dimensions 177x44x44mm, 193g. Must be mounted with ethernet poin
Operating temperature -30C to +70C
Operating system MikroTik RouterOS v5, Level4 license (station, point-to-po
Package contains Metal 5SHPn unit, mounting loops, PoE injector, 24V pow
RX sensitivity 802.11a: –93 dBm @ 6Mbps to -77 dBm @ 54 Mbps
802.11n: –93 dBm @ MCS0 to –71 dBm @ MCS7
TX power 802.11a: 31dBm @ 6Mbps to 27dBm @ 54 Mbps
802.11n: 30dBm @ MCS0 to 26dBm @ MCS7
Modulations OFDM: BPSK, QPSK, 16 QAM, 64QAM
DSSS: DBPSK, DQPSK, CCK


Надеюсь в Украине данный девайс появится в продаже в ближайшее время так как прошлой весной грабом побило довольно много и NanoBridge, Bullet, и просто пигтейлов на стыке  с выносной антенной.

Mikrotik RouterBoard 951-2n

RB951-2n  это продолжение линейки Wi-Fi роутеров серии  RB750/751.
RB951-2n имеет на борту 300Мгц процессор и 32 мб оперативной памяти что вполне достаточно для обработки достаточно большого объема трафика. Надеюсь что в украинских магазинах этот роутер появится в ближайшее время.

Вот более подробрные характеристики

CPU Atheros AR9331 300MHz CPU
Memory 32MB DDR SDRAM onboard memory
Ethernet Five independent 10/100 Ethernet ports
LEDs Power, NAND activity, 5 Ethernet LEDs
Power options PoE:  8-30V DC on Ether1 (Non 802.3af). Jack: 8-30V DC
Dimensions 113x89x28mm. Weight without packaging and cables: 142g
Power consumption Up to 4W
Operating Temp -20C .. +50C
Operating System MikroTik RouterOS, Level4 license
Package contains RouterBOARD in a plastic case, power adapter
Antennas 1x1 MIMO with two onboard PIF antennas, max gain 1.5dBi
TX power 802.11b: 17dBm @ 11Mbps
802.11g: 15dBm @ 6Mbps to 11 dBm @ 54 Mbps
802.11n: 15dBm @ MCS0 to 9dBm @ MCS7 40MHz
RX sensitivity 802.11g: -92dBm @ 6Mbit/s to -73dBm @ 54Mbit/s
802.11n: –92 dBm @ MCS0 to –67 dBm @ MCS7
Modulations OFDM: BPSK, QPSK, 16 QAM, 64QAM
DSSS: DBPSK, DQPSK, CCK

и фото



Для тех кто запутался в классификации RouterBoard от Mikrotik

среда, 28 марта 2012 г.

Интернет на море. Канакская балка

Ура Интернет все дальше пробирается по Крымскому побережью.
     Летом заработает бесплатная Wi-Fi зона в Канакской Балке - А точнее в пансионате Каспий и на всех его объектах. Так что всех приглашаю в это удивительной красоты место, которое находится на 38 км трассы Алушта - Судак. " километра  широкого пляжа расположились между красивейших гор... Чистая вода, рыба, мидии крабы на скалах....
О тестировании скорости и подробностях реализации расскажу недели через 2.
К стати проектом занимается компания IT Service Crimea поэтому я уверен результаты не разочаруют.

понедельник, 26 марта 2012 г.

Ubiqiuiti AirFiber или 1.4 Gbps по радиоканалу.

Сегодня появился UBNT - AirFiber DS - Это новое поколение радиодевайсов работающих на частоте 24 ггц. Заявленная пропускная способность этого комплекта 1.4 gbps на расстоянии до 13 км. Данный мост уже доступен для пред заказа на ubnt.com цена 3000$ за комплект.
Вот полные технические характеристики на этот мост:

Рабочая частота                                   24.05 – 24.25 GHz
Габариты                                             649 x 426 x 303 mm
Вес                                                       10.5 kg (Mount Included)
Максимальное потребление энергии   < 50W
Рабочее напряжение                          50V, 1.2A PoE GigE Adapter (Included)
Адаптер                                               Passive Power over Ethernet (42-58VDC)
Сертификаты                                      CE, FCC, IC
Крепление                                          Pole Mount Kit (Included)
Рабочая температура                         -40 to 55°C (-40 to 131° F)
Светодиоды                                       (8) Status LEDs: Data Port Speed
                                                            Data Port Link/Activity
                                                            Confguration Port Speed
                                                            Confguration Port Link/Activity
                                                            GPS Synchronization
                                                            Modulation Mode
                                                            Master/Slave
                                                            RF Status
                                                            (1) Two-Digit LED Display Calibrated in dBm
Интерфейсы                                       Data Port (1) 10/100/1000 Ethernet Port
                                                            Confguration Port (1) 10/100 Ethernet Port
                                                            Auxiliary Port (1) RJ-12, Alignment Tone Port
Система
Max пропускная способность          1.4+ Gbps
Max растояние                                  13+ km
Пакетов в секунду                         > 1 Million
Шифрование                                     128-Bit AES
Forward Error Correction                    164/205
Cyclic Prefx                                         1/16 Fixed
Uplink/Downlink Ratio                         50% Fixed
GPS                                                    GPS Clock Synchronization
Радио
EIRP                                                  ~33 dBm
Frequency Accuracy                            +/-2.5 ppm without GPS Synchronization 
+/- 0.2 ppm with GPS Synchronization
Channel Bandwidth                              100 MHz
Operating Channels                              24.1 GHz, 24.2 GHz
Modulation                                          64QAM MIMO
                                                           16QAM MIMO
                                                           QPSK MIMO
                                                           QPSK SISO
Integrated Split Antenna
                                                             Gain 33 dBi
                                                             Beamwidth < 3.5°
Front-to-Back Ratio                              30 dB
Polarity                                                  Dual-Slant Polarization
Cross-Polarity Isolation                          > 28 dB






Надеюсь Украинские поставщики не будут тянуть и импортом этой девайсов и опробовать их получится уже этим летом.

четверг, 22 марта 2012 г.

MikroTik Cloud Core Router: CCR-1036

Уже к лету компания Mikrotik собирается выпустить новый флагманский маршрутизатор CCR-1036. Это будет 1 маршрутизатор Mikrotik с SFP/10 gb портами за борту и общей пропускной способностью 16 Gbps.
36 ядер PPC CPU (1.2Ghz на ядро)
4x SFP порта  10 GB
12x гигабитных портов
Сенсорный LCD экран
15mpps и 16Gbit пропускной способности
1U корпус для 19" стойки
ориентировочная стоимость этого девайса : $1500-$1800USD
Ждем с нетерпением.


вторник, 20 марта 2012 г.

Установка VMtools вручную.

Частенько бывает что автоматическая установка VMtools  проходит с ошибкой. В системах с графической оболочкой нет проблем установить VMware tools так как он имеет достаточно простой инсталятор. Но в  Linux системах без графического интерфейса весь процесс установки необходимо производить вручную.
И так будем исходить из того что VM выдала ошибку при установке VMtools. В этом случае диск уже вставлен в виртуальный CDROM, примонтируем его.
mkdir /media/cd
mount /dev/cdrom /media/cd
скопируем архив с программой и разархивируем ее.
cp /media/cd/VMware-tools_curren-realise_.tar.gz  /tmp
cd /tmp
tar xzf VMware-tools_curren-realise_.tar.gz
cd vmeare-tools_curren-realise
./vmware_tools.pl -d
ключ -d производит установку с параметрами по умолчанию.
установленная VMtools занимает на винте около 200 мб
столько же разархивированный архив, и 70 мб архив с инсталятором.
для удаления VMware tools последнюю команду замените на
bin/uninstall_vmtools.pl

четверг, 15 марта 2012 г.

Linux apache не работает SSL file not found

Не так давно столкнулся с такой ошибкой
на 80 порту apache отдает документ нормально на 443 выдает ошибку file not found.
хотя ничего лишнего в конфиге и htacces небыло, да и смотрели оба Vhosts в 1 папку.
Посkt продолжительных экспериментов было выяснено сто на тестовой машине этот конфиг работает без проблем.
В итоге как оказалось дьявол кроется в мелочах
Apache/2.2.15 не понимает <IfDefine SSL>
но прекрасно понимает <IfDefine SSL_module>.
Так что будьте внимательнее коллеги.

суббота, 3 марта 2012 г.

Настройка SSTP соединений на маршрутизаторах Mikrotik.

 Secure Socket Tunneling Protocol (SSTP)  - это транспорт использующий PPP туннель поверх SSL 3.0 канала. Использование SSL на TCP-порт 443 SSTP позволяет передавать  через практически все брандмауэры и прокси-серверов.





  • TCP соединение устанавливается от клиента к серверу. (по умолчанию используется 443 порт);
  • SSL Проверяется сертификат сервера. Если сертификат валидный соединение устанавливается, если нет соединение сбрасывается.
  • Клиент отправляет контрольный SSTP пакет через HTTPS сессию, который устанавливает SSTP сессию на обоих машинах.
  • PPP общается с сервером поверх SSTP. Клиент проходит авторизацию на сервере, и получает связку IP адрес и SSTP интерфейс.
  •  SSTP тунель установлен и можно передавать информацию.

   
Примечание:
Если используются 2 устройства Mikrotik то можно создать SSTP туннель без сертификатов с любым доступным методом авторизации.
В иных конфигурациях для создания защищенных туннелей с MSCHAP авторизацией использование сертификатов обязательно.

Корректно SSTP работает только на Windows Vista, Windows 7 и RouterOS.

Сертификаты.

Для настройки SSTP туннеля необходимы сертификаты. На сервере проверка подлинности происходит по логину\паролю, но
на клиент серверное соединение производит проверку сертификата. Также сертификаты необходимы для SSL и PPP соединения.
Если SSTP клиенты - это Windows-ПК то для настройки SSTP туннеля необходимо импортировать самоподписаный сертификат сервера в систему и пометить этот сертификат как доверенный.

Настройка SSTP клиента.

Sub-menu: /interface sstp-client

Опции


add-default-route (yes | no; Default: no)     Задать ip адресс SSTP сервера как шлюз по умолчанию.
authentication (mschap2 | mschap1 | chap | pap; Default: mschap2, mschap1, chap, pap) Выбор метода проверки подлиности.
certificate (string | none; Default: none)     Использование сертификата.
comment (string; Default: )     Задать коментарий для соединения.
connect-to (IP:Port; Default: 0.0.0.0:443)     ip адресс и порт удаленного SSTP сервера.
dial-on-demand (yes | no; Default: no)    
disabled (yes | no; Default: yes)     Включение\выключение интерфейса.По умолчанию выключен.
keepalive-timeout (integer | disabled; Default: 60) Максимальное время простоя соединения. по умолчанию 60 секунд.   
max-mtu (integer; Default: 1500)     Максимальный размер пакета отправляемого через SSTP интерфейс.
mrru (disabled | integer; Default: disabled)     Максимальный размер пакета проходяшего через SSTP интерфейс.Если пакет больше чем MTU, он будет разбит на несколько пакетов.
max-mru (integer; Default: 1500)     Максимальный размер пакета получаемого через SSTP интерфейс.
name (string; Default: )     Задать имя для соединения.
password (string; Default: "")     Пароль для авторизации.
profile (name; Default: default-encryption)     Выбор PPP профиля.
proxy (IP:Port; Default: 0.0.0.0:443)     Адресс и порт HTTP прокси сервера.
user (string; Default: )     Амя пользователя используемое при авторизоции.
verify-server-certificate (yes | no; Default: no)     Проверка сертификата сервера.
verify-server-address-from-certificate (yes | no; Default: yes)     Проверка ip адреса сервера и сертификата.

Настройка в терминале:

[admin@SSTP-client]  /interface sstp-client>add user=sstp-test password=123 \
\... connect-to=10.10.10.1 disabled=no
[admin@SSTP-client] /interface sstp-client> print
Flags: X - disabled, R - running
 0  R name="sstp-out1" max-mtu=1500 max-mru=1500 mrru=disabled connect-to=10.1.101.1:443
      user="sstp-test" password="123" proxy=0.0.0.0:443 profile=default
      certificate=none keepalive-timeout=60 add-default-route=no dial-on-demand=no
      authentication=pap,chap,mschap1,mschap2
     
      Настройка SSTP Сервера.

Sub-menu: /interface sstp-server server

Опции:
authentication (mschap2 | mschap1 | chap | pap; Default: mschap2, mschap1, chap, pap) Выбор метода проверки подлиности.
certificate (name | none; Default: none)  Имя сертификата сервера.
default-profile (name; Default: default)     Имя профиля
enabled (yes | no; Default: no)                Включение\выключение сервера.
verify-client-certificate (yes | no; Default: no) Проверка сертификата клиента.
keepalive-timeout (integer | disabled; Default: 60) Максимальное время простоя соединения. по умолчанию 60 секунд.   
max-mtu (integer; Default: 1500)     Максимальный размер пакета отправляемого через SSTP интерфейс.
mrru (disabled | integer; Default: disabled)     Максимальный размер пакета проходяшего через SSTP интерфейс.Если пакет больше чем MTU, он будет разбит на несколько пакетов.
max-mru (integer; Default: 1500)     Максимальный размер пакета получаемого через SSTP интерфейс.

Настройка в терминале. 

[admin@SSTP-server] /interface sstp-server server> set certificate=server
[admin@SSTP-server] /interface sstp-server server> set enabled=yes
[admin@SSTP-server] /interface sstp-server server> print
                     enabled: yes
                        port: 443
                     max-mtu: 1500
                     max-mru: 1500
                        mrru: disabled
           keepalive-timeout: 60
             default-profile: default
                 certificate: server
  verify-client-certificate: no
              authentication: pap,chap,mschap1,mschap2
[admin@SSTP-server] /interface sstp-server server>



Мониторинг:

[admin@SSTP-server] /interface sstp-server> monitor 0
     status: "connected"
     uptime: 13m22s
  idle-time: 13m22s
       user: "sstp-client1"
  caller-id: "10.10.10.11:815"
        mtu: 1500
       
Настройка удаленного клиента.

Создадим пользователя.

[admin@MTtest] /ppp secret> add name=notebook service=sstp password=123
local-address=10.10.10.1 remote-address=10.10.10.100
[admin@MTtest] /ppp secret> print detail
Flags: X - disabled
  0   name="notebook" service=sstp caller-id="" password="123" profile=default
      local-address=10.10.10.1 remote-address=10.10.10.100 routes==""

[admin@MTtest] /ppp secret>       
       
Включим SSTP  сервер.

[admin@MTtest] /interface sstp-server server> set certificate=server
[admin@MTtest] /interface sstp-server server> set enabled=yes
[admin@MTtest] /interface sstp-server server> set authentication=mschap2
[admin@MTtest] /interface sstp-server server> print
                     enabled: yes
                        port: 443
                     max-mtu: 1500
                     max-mru: 1500
                        mrru: disabled
           keepalive-timeout: 60
             default-profile: default
                 certificate: server
  verify-client-certificate: no
              authentication: mschap2

[admin@MTtest] /interface sstp-server server>

Вот и все удаленные не Mikrotik клиенты могут подключатся к нам с использованием авторизации mschap2.

Проверим подключение.

[admin@MTtest] /interface sstp-server> print
Flags: X - disabled, D - dynamic, R - running
 #     NAME      USER         MTU        CLIENT-ADDRESS    UPTIME   ENCODING  
 0  DR <sstp-... notebook     1500       10.10.10.108:6586 4h12s 

[admin@MTtest] /interface sstp-server>monitor 0
     status: "connected"
     uptime: 4h10s
  idle-time: 4h10s
       user: "notebook"
  caller-id: "192.168.10.18:6586"
        mtu: 1500
       
Если подключение успешно - включаем proxy-arp.

[admin@MTtest] /interface ethernet> set ether2 arp=proxy-arp
[admin@MTtest] /interface ethernet> print
Flags: X - disabled, R - running
  #    NAME                 MTU   MAC-ADDRESS         ARP
  0  R ether1              1500  00:f0:1F:02:7B:C1 enabled
  1  R ether2              1500  00:f0:AF:F6:62:12 proxy-arp
[admin@MTtest] interface ethernet>


пятница, 2 марта 2012 г.

Mikrotik RouterOS Firewall IPv6 manual

IPv6 уверенно входит в нашу жизнь и на просторах русскоязычного сообщества вот вот появятся провайдеры работающие только на IPv6.
В связи с этим небольшой ман по настройке firevall для протокола IPv6 на RouterOS.
Sub-menu: /ipv6 firewall filter

1)   action (accept | add-dst-to-address-list | ...; Default: accept)

Возможные параметры:
  • accept - пропустить пакет..
  • add-dst-to-address-list - добавить IP получателя в address list.
  • add-src-to-address-list - добавить IP отправителя в address list.
  • drop - удалить пакет.
  • jump - Перейти к пользовательской цепочке правил или применить jump-target параметр.
  • log - добавить сообщение в системный лог. 
  • passthrough - игнорировать данное правило и перейти к следующему.
  • reject - удалить пакет.  и отправить ICMP отчет об удалении.
  • return - Passes control back to the chain from where the jump took place.

2) address-list (; Default: )
3) time (; Default: )

четверг, 23 февраля 2012 г.

Обновление Router OS 5.14 от 22.02.2012

Доступна новая версия Router OS 5.14. Скачать ее можно здесь.
В новой версии:
  1. Winbox - исправлена проблема с изменением размера главного окна.
  2. Backup - исправлена проблема с созданием бекапов для устройств в имени которых используется "\".
  3. Wireless - Улучшена стабильность nv2. Уменьшено время прохождения пакета. Требует только обновления AP.
  4. Исправлена проблема с конфигурацией на RB1100AHx2.
  5. Сertificate manager - Исправлена проблема доверия к цепочке сертификатов, для некоторых программ.

среда, 22 февраля 2012 г.

Настройка Nstreme dual на Mikrotik Router OS

Технология Nstreme dual в RouterOS позволяет объединить несколько физических Wlan интерфейсов в 1 логический. Принцип данной технологии немного отличается от описанного в прошлом посте OSFP и имеет свои достоинства и недостатки. В основном же данная технология отличается высокой надежностью, и почти  двукратным увеличением скорости.
И так настройка из консоли:

MikroTik 1.


Влючаем Wi-Fi карточки.

[admin@test-493G] > interface enable wlan1.
[admin@test-493G] > interface enable wlan2

Задаем IP адрес для Ethernet интерфейса.

[admin@test-493G] > ip address add address=192.168.1.1/24 interface=ether1.

Создаем bridge интерфейс.
 
[admin@test-493G] > interface bridge add .

Добавляем интерфейс Ethernet в интерфейс bridge.
 
[admin@test-493G] > interface bridge port add interface=ether1 bridge=bridge1

Зададим для Wi-Fi карт режим работы nstreme.
 
[admin@test-493G] > interface wireless set wlan1 mode=nstreme­-dual­-slave
[admin@test-493G] > interface wireless set wlan2 mode=nstreme­-dual­-slave 

Создадим nstreme dual интерфейс и настроим RX/TX частоту.

[admin@test-493G] > interface wireless nstreme­-dual add rx­-radio=wlan1 tx­-radio=wlan2
rx-­band=5ghz tx-­band=5ghz rx-­frequency=5380 tx­-frequency=5200

Добавим интерфейс nstreme в Bridge.

[admin@test-493G] > interface bridge port add interface=nstreme1 bridge=bridge1

Проверяем MAC адрес nstreme интерфейса.

[admin@test-493G] > interface wireless nstreme­dual print
Flags: X ­ disabled, R ­ running
0 X  name="nstreme1" mtu=1500 mac­address=00:11:22:33:44:55 arp=enabled
disable­running­check=no tx­-radio=wlan2 rx­-radio=wlan1 remote­mac=00:00:00:00:00:00
tx-­band=5ghz tx­-frequency=5300 rx­-band=5ghz rx­-frequency=5180
rates­b=1Mbps,2Mbps,5.5Mbps,11Mbps
rates­a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
framer­policy=none framer­limit=2560

MikroTik 2.


Влючаем Wi-Fi карточки.

[admin@test2-493G] > interface enable wlan1.
[admin@test2-493G] > interface enable wlan2

Задаем IP адрес для Ethernet интерфейса.

[admin@test2-493G] > ip address add address=192.168.1.2/24 interface=ether1.

Создаем bridge интерфейс.
 
[admin@test2-493G] > interface bridge add .

Добавляем интерфейс Ethernet в интерфейс bridge.
 
[admin@test2-493G] > interface bridge port add interface=ether1 bridge=bridge1

Зададим для Wi-Fi карт режим работы nstreme.
 
[admin@test2-493G] > interface wireless set wlan1 mode=nstreme­-dual­-slave
[admin@test2-493G] > interface wireless set wlan2 mode=nstreme­-dual­-slave 

Создадим nstreme dual интерфейс и настроим RX/TX частоту.

[admin@test2-493G] > interface wireless nstreme­-dual add rx­-radio=wlan1 tx­-radio=wlan2
rx­-band=5ghz tx-­band=5ghz rx-­frequency=5200 tx­-frequency=5380
remote­mac=00:11:22:33:44:55 disabled=no

Добавим интерфейс nstreme в Bridge.

[admin@test2-493G] > interface bridge port add interface=nstreme1 bridge=bridge1

Проверяем MAC адрес nstreme интерфейса.

[admin@test2-493G] > interface wireless nstreme­dual print
Flags: X ­ disabled, R ­ running
0  R name="nstreme1" mtu=1500 mac­address=22:33:44:55:66:77 arp=enabled
disable­running­check=no tx­-radio=wlan2  rx­-radio=wlan1 remote­mac=00:11:22:33:44:55
tx­-band=5ghz tx-­frequency=5180 rx-­band=5ghz rx-­frequency=5300
rates­b=1Mbps,2Mbps,5.5Mbps,11Mbps
rates­a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
framer­policy=none framer­limit=2560

MikroTik 1

Настраиваем удаленный МАС адрес на Mikrotik 1

[admin@test2-493G] > interface wireless nstreme­-dual set nstreme1
remote­mac=22:33:44:55:66:77 disabled=no

Все теперь RX и TX передаются на разных частотах, разных карточках и разных антеннах. Резерв на случай отказа карточки, битого пигтейла и сдутой антенны у нас есть.

Удачи вам. 
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.

Распаралеливание каналов Rx/Tx по Wi - Fi с помощью OSFP

И так  есть задача построить радиоканал с хорошей пропускной способностью, надежный, с минимальной задержкой пакетов (что критично например для VoIP).

Для реализации нам понадобятся:
  • 2 RouterBoard с  2 более miniPCI слотами.
  • 4 Wi-fi карты miniPCI способные работать в диапазоне 5Ггц.
  • 4 Внешних антены.
  • 4 комплекта пигтейлов.
  • 2 антенабокса.
На оборудовании компании Mikrotik схема предложенной реализации выглядит примерно так:


Плюсы данной схемы:
  1. Full Duplex.
  2. Автоматическая балансировка нагрузки между каналами.
  3. Низка задержка  пакетов. (почти вдвое меньше по сравнению с N-Streme-Dual
  4. Автоматическое переключение на один канал при выходе из строя другого.
  5. Увеличение пропускной способности радиочасти.

Через консоль эта конфигурация настраивается примерно так:


Для роутера А.


/ip address add address=192.168.0.1/24 interface=ether1
/ip address add address=192.168.10.1/24 interface=wlan1
/ip address add address=192.168.20.1/24 interface=wlan2
/routing ospf network add network=192.168.10.0/24 area=backbone1
/routing ospf network add network=192.168.20.0/24 area=backbone1
/routing ospf interface add interface=wlan1 cost=100
  
Для роутера Б.
 
/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.10.2/24 interface=wlan1
/ip address add address=192.168.20.2/24 interface=wlan2
/routing ospf network add network=192.168.10.0/24 area=backbone1
/routing ospf network add network=192.168.20.0/24 area=backbone1
/routing ospf interface add interface=wlan2 cost=100 
 
Этот конфиг означает что роутер А будет ждать входящий трафик на интерфейсе wlan1
а роутер Б на интерфейсе Wlan2.

Удачи вам. 
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.


 

вторник, 21 февраля 2012 г.

Backup настроек Mikrotik RouterOS с сохранением на FTP сервер.

В предыдущей статье я писал как настроить отправку бекапа на Email. Но данная конфигурация не всегда удобна так как не у всех есть свой почтовый сервер да и не всем он необходим. Зато с организацией FTP сервера проблем обычно не возникает (Слава Filezilla) настраивается за 5 минут на любой операционке. Туда мы и будем складывать наши ежедневные бекапы.Либо можем настроить FTP сервер на Mikrotik и задирать бекапы средствами сервера.

И так настройка из консоли:

# создаем  scheduler который раз в 10 часов создает бекап системы.

/system scheduler 
add name="settings_backup" on-event="system backup save name=today.backup" \
    start-date=jan/01/1970 start-time=00:00:00 interval=10h comment="" \
    disabled=no
 
# Проверяем включен ли ftp сервер. 
 
/ip service print
Flags: X - disabled, I - invalid 
 #   NAME      PORT  ADDRESS       CERTIFICATE    
 0   telnet    23    0.0.0.0/0    
 1   ftp       21    0.0.0.0/0    
 2   www       80    0.0.0.0/0      
 3   ssh       22    0.0.0.0/0    
 4 X www-ssl   443   0.0.0.0/0     none
 5 X api       8728  0.0.0.0/0    
 6   winbox    8291  0.0.0.0/0   

# Создаем пользователя и даем ему права ходить на ftp.

/user group 
add name="ftp" policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!test,!winbox,!password,!web,!sniff
/user 
add address=0.0.0.0/0 comment="backup ftp mikrotik" disabled=no group=ftp name="ftp"
/user 
set [find name="ftp"] password="mypassword"
 
С настройкой микротика мы закончили. Теперь настроим серверную часть.
 
Для Unix систем я недавно постил подобный скрипт на Perl,
 в котором выполняется подобная задача. Цтобы адаптировать скрипт под наши нужды,
 необходимо изменить переменную $filename="today.backup"; и последний запрос 
$ftp->put($filename) or die "Can't connect: $@\n" ;
изменить на 
$ftp->get($filename) or die "Can't connect: $@\n";
Для Windows систем все немного сложнее.
Нам будет необходимо приложение mtbackup.exe.
Создадим шаблон template1.s с текстом:
 
o 192.168.0.1 21
USER ftp
mypass
binary
$
192.168.0.1 – Router backup
close
quit
 
Теперь запустим вручную этот скрипт с шаблоном.
 
C:\mtbackup\mtbackup.exe "c:\mtbackup\template1.s" "c:\mtbackup\backups"
 
В папке c:\mtbackup\backups\ должен появится первый файл.
Если все прошло нормально можно ставить резервное копирование по расписанию.
 
Удачи вам в работе.
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.
 
 
 

Автоматический Backup на Mikrotik RouterOS через Email.

E-mail backups. - очень удобно если есть собственный почтовый сервер на микротике с консоли это настраивается так: 

/tool e-mail print # Смотрим настройки мыла
 
 server: 192.168.0.1 # smtp server
 from: mikrotik_backup_01@server.local 
# Почтовый ящик с которого будут отправлять бекапы
введем эти настройки 
/tool e-mail set server=192.168.0.1 mikrotik_backup_01@server.local 
 
 
/tool e-mail send to="admin@host.com" subject=([/Router_01]." backup") 
file=email.backup;
:log info "Backup e-mail sent."; } 
теперь добавим эту команду в scheduler чтобы она выполнялась автоматически.
 
/system scheduler 
add comment="System backup" disabled=no interval=1d name="e-mail_backup" \
on-event=e_mail_backup start-date=jan/01/1970 start-time=00:00:00 
Все теперь каждый день в 00:00:00 вам на почту будет 
приходить бекап системных настроек с роутера микротик.
 
Удачи вам. 
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.
 


понедельник, 20 февраля 2012 г.

Простой скрипт для бекапа файлов на удаленный FTP серер

Возникла задача периодически сливать файлы на удаленный ftp сервер. Наиболее быстрый способ решить эту задачу - написать его скрипт на Perl
Вот весь код:


#!/usr/bin/perl -w
  my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime time; #получаем дату.(я в скрипте использую только $mday $mon и $year так как более подробная информация мне не нужна. Вы де можете использовать необходимое количество нужных переменных.)

system("rm -rf /voip/wav.*");  # Очищаем временную папку.
system("mv /voip/*.wav /voip/wav/"); # Перемешаем все необходимые файлы во временную папку.
system("tar czf /voip/wav\_$year\_$mon\_$mday\.tar.gz /voip/wav/*"); # архивируем временную папку. Имя архива в формате имя_год_месяц_день-создания.tar.gz

    $username="ftpuser"; #задаем ftpusername
    $password="ftppassword";# задаем ftppassword
    $filename="/voip/wav\_$year\_$mon\_$mday\.tar.gz"; # задаем имя архива который будем копировать по ftp
    use Net::FTP; # подключаем модуль Net::FTP
    $ftp = Net::FTP->new("ftp.server.loocal") or die "Couldn't connect\n"; # подключаемся к серверу.
    $ftp->login($username, $password) or die "Couldn't change login\n"; # Проверка логина/пароля
    $ftp->binary or die "Couldn't get binary";  # включаем режим передачи бинарных файлов.
    $ftp->put($filename) or die "Can't connect: $@\n"; # Заливаем файл на сервер.

Вот и все осталось только прописать запуск этого скрипта в кроне в нужное для нас время. С ие забыть дать права на запуск
chmod 7XX  /путь/к/файлу/скрипт.pl
Удачи вам в работе.
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.

пятница, 17 февраля 2012 г.

Router OS 5.13, 5.12, 5.6

14.02.2012 вышли в свет обновления для RouterOS версий 5.13, 5.12, 5.6.  Ничего фундаментального в них не поменялось но кое что все-таки исправили. Вот список изменений.
Для версии 5.12


Консоль - команду passwd теперь можно использовать в скриптах и API.
Winbox - реорганизована работа с консолью.
SSH - исправлена проблема с psftp.
Добавлен SMB server.
Исправлена ошибка с ovpn-client.
Исправлена ошибка с ipv6 neighbor discovery.
Консоль  исправлены минорные ошибки.
Консоль - добавлена поддержка compact export.

Hotspot - Добавлен редирект при статусе http 302;
Wi-Fi -  Добавлен дефолтный конфиг для карт  R5SHPn.
PPP - Исправлена проблема с  remote-ipv6-pool.
Winbox, Webfig - Добавлена сортировка интерфейсов.
Добавлен QuickSet для RBSXT, RB411, RB711.Добавдена поддержка LTE модемов.

Для версии 5.13

Firewall - to-address теперь можно задать как сеть.маска.
Traffic-generator - исправлена проблема с падениями на многоядерных системах.
SMB - Исправлено и улучшено.
Dhcp client - Исправлено и улучшено.
Quickset -  страна & channel-width не зависят друг от друга.
Quickset - Добавленна поддержка PPPOE соединений через Wi-Fi интерфейс.
Bridge -Испраслена проблема с arp reply-only
Webfig -
Webfig - отображается окно ввода логина\пароля  при неудачном авто логине;

 Для версии 5.6
BGP -  Допущены параллельные операции согласно RFC4761 "l2vpn" and
draft-ietf-l2vpn-signaling "l2vpn-cisco" BGP VPLS.
 Консоль - команда ":resolve" возвращает IPv6 адрес для хостов которые используют IPv.6.
SNMP - Добавлена поддержка UPS с отображением уровня заряда батареи.
Route -Исправлена проблема с SNMP трафиком.

Mikrotik RB751, RB751G, Mikrotik RB400L series, R5SHPN, OmniTIK UPA-5HnD. Новинки от копмании Mikrotik.

В январе этого года компания Mikrotik немного обновила свой модельный ряд о чем я писал ранее. В январе этого года появились на свет несколько новых устройств RouterBoard 751,RouterBoard 751G, серия RouterBoard 400L, 5 ггц карточка R5SHPN, и  OmniTIK UPA-5HnD. Давайте рассмотрим подробнее что же нового в этих устройствах.
Mikrotik RB751 - это компактный wireless SOHO AP Router в симпатичном белом корпусе с 5х100mbps и1 USB портами на борту и 802.11b/g/n WI-FI карточкой. Зная продукты компании микротик качество исполнения остается на высоте.
Mikrotik RB751G - тоже самое только с гигабитными портами.
Эти 2 RouterBoard являются прямым продолжением линейки RouterBoard 750 и 750G, которые отлично зарекомендовали себя в работе.
Mikrotik RB400L series это новая линейка RouterBoard вышедшая из серии RB400 которую немного урезали и упростили. Пока в этой серии только 4 устройства:
RB411L 
RB433L
RB433UAHL
RB433GL 
RouterBoard 411L и RouterBoard 433L не имеют com порта и питаются только через PoE.
RouterBoard 411L имеет  на борту слот MiniPCI.
RouterBoard 433GL имеет отдельный вход для питания, Гигабитный порт и 3 MiniPCI слота.
R5SHPN - Это новая супер мощная Wi-Fi 5GHz Карточка. Главной особенностью этой карточки помимо мощности в 800mW являются 9 светодиодов, которые покажут вам состояние подключения, качество сигнала и RX/TX,  
OmniTIK UPA-5HnD - всепогодная базовая станция 5GHz 802.11a/n. Наиболее оптимально работает с устройствами серии SXT. Имеет 5 10/100 Ethernet портов, PoE и 400mW 802.11a/n Wi-Fi адаптер. Благодаря поддержке технологии Nv2  TDMA суммарная пропускная способность выросла до 200mbps. Наличие USB порта и последней версии RoutrerOS подключить 3G модем теперь не составляет большого труда.
Более подробно эти девайсы я опишу когда они появятся на Украинском рынке. 
Удачи.

среда, 15 февраля 2012 г.

Mikrotik default IP

В связи с тем что поток вопросов о дефолтном IP на микротиках не прекращается напишу об этом целую статью.
1: Default IP для всех устройств компании Mikrotik 192.168.88.1
2: Если вы забыли какой IP установили на Микротике - Winbox найдет этот микротик по маку и зайдет не него без проблем. Главное чтобы вы были в одной сети.
3: Если вы не помните Vlan и IP см п2.
4: Если вы не помните Vlan и IP и в разных логических сетях или микротик подключен по радио то на него можно зайти через Mac telnet с другого устройства компании Mikrotik.
5: Ничего из вышеперечисленного не помогло - это не повод ресетить девайс - можно подключится через com порт но это не для всех девайсов.

к стати default login/password на Mikrotik это admin/admin

понедельник, 13 февраля 2012 г.

Mikrotik RB1100AHx2

Вышел новый Mikrotik RB1100AHx2.  Это достойное продолжение линейки аппаратных маршрутизаторов Mikrotik и впервые в линейке с двух ядерным процессором. Более подробные характеристики RB1100AHx2

  • Процессор                       P2020 / 1066MHz.
  • RAM                                2GB
  • Архитектура                    PPC
  • Количество портов GB 13
  • Карты памяти                1 microSD
  • PoE                                  10-28V
  • Формат                           1U case: 44 x 176 x 442 mm, 1200g. Board only: 365g
  • Операционная система RouterOS
 По заявлениям производителя эта железяка может вытянуть до 1 000 000 pps. Будем на это надеяться. Как только данный девай попадет мне в руки сразу отпишусь по проведенных тестах.

Альтернативя Microsoft Exchange для Linux.

При переводе офиса с Windows на Linux перед системным администратором возникает огромное количество проблем. Основная проблема - это как подобрать софт не уступающий Windows аналогам. Процесс этот обычно трудный длительный и часто упирается в такой момент - когда нет возможности заменить весь софт организации одновременно и всем не запуская параллельно 2 серверные площадки.
После долгого и мучительного изучения free  приложений для замены Mikrosoft Exchange я нашел очень интересное решение  Synovel Collabsuite - Linux Mail Server with Calendaring and IM. Хороший сервис - незаслуженно обделенный вниманием росийских админов судя по количеству русскоязычных отзывов.
И так что же представляет из себя  Synovel Collabsuite Server? Это Linux based Email server, календарь сервер (протокол Caldav), сервер контактов и сервер мгновенный сообщений.
Помимо сервера к этому всему еще идет и мультиплатформенный десктопный клиент Spicebird на основе Thunderburd.




 Подробнее о возможностях: 
  • Email server - SMTP, POP3 and IMAP
  • Webmail - Ajax, re-branding support
  • Calendar server - Caldav protocol
  • Instant messaging server - Jabber protocol
  • Anti-virus and Anti-spam
  • Archival system with robust search
  • Admin panel - Web based, simplified and intuitive
  • Active Directory® integration
  • CentOS® Directory Server integration
  • Automatic data backups
  • Server monitoring, statistics
И еще много других интересных вкусностей и полезностей позволяющий рассматривать  Synovel Collabsuite как серьезную альтернативу Microsoft Exchange. Для больший компаний и гос предприятий существуем комерческая версия ноторя отличается немного более расширенным функционалом и поддержкой. Но для моих задач мне вполне хватает synovel. Да и вопросов по его установке небыло - все подробно описано в мануале да ит работает нормально из коробки - сразу видно что для людей делалось. 
Стоит отметить реально удобную панель администратора. Я сначла из консоли всем рулил по привычке, но сейчас уже через веб удобней стало. Так быстрее и проще.
Вот с помощью такого нехитрого инструмента можно отправить в АД Microsoft Exchange и установить Linux bases  систему всего за одни выходные. А клиентов перевести это дело техники и времени так как Synoven Spacebird  это кроссплатформенное решение.
Удачи в реализации!

воскресенье, 8 января 2012 г.

Удивило. В Украине есть нормальный хостинг

Периодически помогаю людям с созданием и размещением сайтов и в силу этого приходилось работать с разными регистроторами и разныыми хостерами. Самые частые проблемы с хостингом - это когда хостинг проплачен на год вперед - а движек сайта под который уже все сверстано и настроенно на этот самый хостинг не становитя. У меня не раз так было. Даже при том что хостер пишет что его хостинг на 100% совметим с данным движкем все равно необходимо проверять. Поэтому в последний год я не работаю с хостинггами которыене предоставляют пробный период.
Еще одна вещь которая мне не нравится ни в Российском ни в Украинском хостинге - это что ни один стандартный движек не ставится на хостинг без танцев с бубном. Нет я понимаю если взял выдеренный сервак или виртуалку. Но когда берешь самый обыкновенный хостинг и неможешь через установщик залить туда Joomla, Drupal или Wordpress. Мне сразу хочется задать вопрос в саппорт - неужели так трудно взять и проверить нормально ли встает движек на хостинг или надо ручками посреди установки проставлять права на файлы, править конфиги или удалить tmp?
Именно по этой причине нет хостинга на который я бы залил больше одного сайта (исключение Godaddy - но там мой выделенный сервак).
С бесплатными хостингами все вообще грустно. Не возможно поставить какой либо современный движек и довести его до ума - не говоря уже о стабильности и простоте использования.
Но недавно я впоисках дома для очередного сайта набрел на hostinger - простой интерфейс - не напрягает рекламой и просьбами перейти с бесплатного хостинга на платный. Вполне нормально для того чтобы поставить движек и допиливать его уже на постоянном хостинге. А после сдаыи проэкта пусть клиент уже решает платить за хостинг или остатся на бесплатном. Мой сайт например жуе третий месяц там живет и на хостинг нареканий нет. Все что хоьел поставилось с пол тычка. Сайт уже проиндексировался и как только начнет приносить хоть какуюто прибыль я конечно начну за него платить - а пока hostinger любезно размещает мой сайт бесплатно - за что им большое спасибо. Найти нормакльный хостинг можно сдесь здесь