четверг, 23 февраля 2012 г.

Обновление Router OS 5.14 от 22.02.2012

Доступна новая версия Router OS 5.14. Скачать ее можно здесь.
В новой версии:
  1. Winbox - исправлена проблема с изменением размера главного окна.
  2. Backup - исправлена проблема с созданием бекапов для устройств в имени которых используется "\".
  3. Wireless - Улучшена стабильность nv2. Уменьшено время прохождения пакета. Требует только обновления AP.
  4. Исправлена проблема с конфигурацией на RB1100AHx2.
  5. Сertificate manager - Исправлена проблема доверия к цепочке сертификатов, для некоторых программ.

среда, 22 февраля 2012 г.

Настройка Nstreme dual на Mikrotik Router OS

Технология Nstreme dual в RouterOS позволяет объединить несколько физических Wlan интерфейсов в 1 логический. Принцип данной технологии немного отличается от описанного в прошлом посте OSFP и имеет свои достоинства и недостатки. В основном же данная технология отличается высокой надежностью, и почти  двукратным увеличением скорости.
И так настройка из консоли:

MikroTik 1.


Влючаем Wi-Fi карточки.

[admin@test-493G] > interface enable wlan1.
[admin@test-493G] > interface enable wlan2

Задаем IP адрес для Ethernet интерфейса.

[admin@test-493G] > ip address add address=192.168.1.1/24 interface=ether1.

Создаем bridge интерфейс.
 
[admin@test-493G] > interface bridge add .

Добавляем интерфейс Ethernet в интерфейс bridge.
 
[admin@test-493G] > interface bridge port add interface=ether1 bridge=bridge1

Зададим для Wi-Fi карт режим работы nstreme.
 
[admin@test-493G] > interface wireless set wlan1 mode=nstreme­-dual­-slave
[admin@test-493G] > interface wireless set wlan2 mode=nstreme­-dual­-slave 

Создадим nstreme dual интерфейс и настроим RX/TX частоту.

[admin@test-493G] > interface wireless nstreme­-dual add rx­-radio=wlan1 tx­-radio=wlan2
rx-­band=5ghz tx-­band=5ghz rx-­frequency=5380 tx­-frequency=5200

Добавим интерфейс nstreme в Bridge.

[admin@test-493G] > interface bridge port add interface=nstreme1 bridge=bridge1

Проверяем MAC адрес nstreme интерфейса.

[admin@test-493G] > interface wireless nstreme­dual print
Flags: X ­ disabled, R ­ running
0 X  name="nstreme1" mtu=1500 mac­address=00:11:22:33:44:55 arp=enabled
disable­running­check=no tx­-radio=wlan2 rx­-radio=wlan1 remote­mac=00:00:00:00:00:00
tx-­band=5ghz tx­-frequency=5300 rx­-band=5ghz rx­-frequency=5180
rates­b=1Mbps,2Mbps,5.5Mbps,11Mbps
rates­a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
framer­policy=none framer­limit=2560

MikroTik 2.


Влючаем Wi-Fi карточки.

[admin@test2-493G] > interface enable wlan1.
[admin@test2-493G] > interface enable wlan2

Задаем IP адрес для Ethernet интерфейса.

[admin@test2-493G] > ip address add address=192.168.1.2/24 interface=ether1.

Создаем bridge интерфейс.
 
[admin@test2-493G] > interface bridge add .

Добавляем интерфейс Ethernet в интерфейс bridge.
 
[admin@test2-493G] > interface bridge port add interface=ether1 bridge=bridge1

Зададим для Wi-Fi карт режим работы nstreme.
 
[admin@test2-493G] > interface wireless set wlan1 mode=nstreme­-dual­-slave
[admin@test2-493G] > interface wireless set wlan2 mode=nstreme­-dual­-slave 

Создадим nstreme dual интерфейс и настроим RX/TX частоту.

[admin@test2-493G] > interface wireless nstreme­-dual add rx­-radio=wlan1 tx­-radio=wlan2
rx­-band=5ghz tx-­band=5ghz rx-­frequency=5200 tx­-frequency=5380
remote­mac=00:11:22:33:44:55 disabled=no

Добавим интерфейс nstreme в Bridge.

[admin@test2-493G] > interface bridge port add interface=nstreme1 bridge=bridge1

Проверяем MAC адрес nstreme интерфейса.

[admin@test2-493G] > interface wireless nstreme­dual print
Flags: X ­ disabled, R ­ running
0  R name="nstreme1" mtu=1500 mac­address=22:33:44:55:66:77 arp=enabled
disable­running­check=no tx­-radio=wlan2  rx­-radio=wlan1 remote­mac=00:11:22:33:44:55
tx­-band=5ghz tx-­frequency=5180 rx-­band=5ghz rx-­frequency=5300
rates­b=1Mbps,2Mbps,5.5Mbps,11Mbps
rates­a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
framer­policy=none framer­limit=2560

MikroTik 1

Настраиваем удаленный МАС адрес на Mikrotik 1

[admin@test2-493G] > interface wireless nstreme­-dual set nstreme1
remote­mac=22:33:44:55:66:77 disabled=no

Все теперь RX и TX передаются на разных частотах, разных карточках и разных антеннах. Резерв на случай отказа карточки, битого пигтейла и сдутой антенны у нас есть.

Удачи вам. 
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.

Распаралеливание каналов Rx/Tx по Wi - Fi с помощью OSFP

И так  есть задача построить радиоканал с хорошей пропускной способностью, надежный, с минимальной задержкой пакетов (что критично например для VoIP).

Для реализации нам понадобятся:
  • 2 RouterBoard с  2 более miniPCI слотами.
  • 4 Wi-fi карты miniPCI способные работать в диапазоне 5Ггц.
  • 4 Внешних антены.
  • 4 комплекта пигтейлов.
  • 2 антенабокса.
На оборудовании компании Mikrotik схема предложенной реализации выглядит примерно так:


Плюсы данной схемы:
  1. Full Duplex.
  2. Автоматическая балансировка нагрузки между каналами.
  3. Низка задержка  пакетов. (почти вдвое меньше по сравнению с N-Streme-Dual
  4. Автоматическое переключение на один канал при выходе из строя другого.
  5. Увеличение пропускной способности радиочасти.

Через консоль эта конфигурация настраивается примерно так:


Для роутера А.


/ip address add address=192.168.0.1/24 interface=ether1
/ip address add address=192.168.10.1/24 interface=wlan1
/ip address add address=192.168.20.1/24 interface=wlan2
/routing ospf network add network=192.168.10.0/24 area=backbone1
/routing ospf network add network=192.168.20.0/24 area=backbone1
/routing ospf interface add interface=wlan1 cost=100
  
Для роутера Б.
 
/ip address add address=192.168.1.1/24 interface=ether1
/ip address add address=192.168.10.2/24 interface=wlan1
/ip address add address=192.168.20.2/24 interface=wlan2
/routing ospf network add network=192.168.10.0/24 area=backbone1
/routing ospf network add network=192.168.20.0/24 area=backbone1
/routing ospf interface add interface=wlan2 cost=100 
 
Этот конфиг означает что роутер А будет ждать входящий трафик на интерфейсе wlan1
а роутер Б на интерфейсе Wlan2.

Удачи вам. 
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.


 

вторник, 21 февраля 2012 г.

Backup настроек Mikrotik RouterOS с сохранением на FTP сервер.

В предыдущей статье я писал как настроить отправку бекапа на Email. Но данная конфигурация не всегда удобна так как не у всех есть свой почтовый сервер да и не всем он необходим. Зато с организацией FTP сервера проблем обычно не возникает (Слава Filezilla) настраивается за 5 минут на любой операционке. Туда мы и будем складывать наши ежедневные бекапы.Либо можем настроить FTP сервер на Mikrotik и задирать бекапы средствами сервера.

И так настройка из консоли:

# создаем  scheduler который раз в 10 часов создает бекап системы.

/system scheduler 
add name="settings_backup" on-event="system backup save name=today.backup" \
    start-date=jan/01/1970 start-time=00:00:00 interval=10h comment="" \
    disabled=no
 
# Проверяем включен ли ftp сервер. 
 
/ip service print
Flags: X - disabled, I - invalid 
 #   NAME      PORT  ADDRESS       CERTIFICATE    
 0   telnet    23    0.0.0.0/0    
 1   ftp       21    0.0.0.0/0    
 2   www       80    0.0.0.0/0      
 3   ssh       22    0.0.0.0/0    
 4 X www-ssl   443   0.0.0.0/0     none
 5 X api       8728  0.0.0.0/0    
 6   winbox    8291  0.0.0.0/0   

# Создаем пользователя и даем ему права ходить на ftp.

/user group 
add name="ftp" policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!test,!winbox,!password,!web,!sniff
/user 
add address=0.0.0.0/0 comment="backup ftp mikrotik" disabled=no group=ftp name="ftp"
/user 
set [find name="ftp"] password="mypassword"
 
С настройкой микротика мы закончили. Теперь настроим серверную часть.
 
Для Unix систем я недавно постил подобный скрипт на Perl,
 в котором выполняется подобная задача. Цтобы адаптировать скрипт под наши нужды,
 необходимо изменить переменную $filename="today.backup"; и последний запрос 
$ftp->put($filename) or die "Can't connect: $@\n" ;
изменить на 
$ftp->get($filename) or die "Can't connect: $@\n";
Для Windows систем все немного сложнее.
Нам будет необходимо приложение mtbackup.exe.
Создадим шаблон template1.s с текстом:
 
o 192.168.0.1 21
USER ftp
mypass
binary
$
192.168.0.1 – Router backup
close
quit
 
Теперь запустим вручную этот скрипт с шаблоном.
 
C:\mtbackup\mtbackup.exe "c:\mtbackup\template1.s" "c:\mtbackup\backups"
 
В папке c:\mtbackup\backups\ должен появится первый файл.
Если все прошло нормально можно ставить резервное копирование по расписанию.
 
Удачи вам в работе.
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.
 
 
 

Автоматический Backup на Mikrotik RouterOS через Email.

E-mail backups. - очень удобно если есть собственный почтовый сервер на микротике с консоли это настраивается так: 

/tool e-mail print # Смотрим настройки мыла
 
 server: 192.168.0.1 # smtp server
 from: mikrotik_backup_01@server.local 
# Почтовый ящик с которого будут отправлять бекапы
введем эти настройки 
/tool e-mail set server=192.168.0.1 mikrotik_backup_01@server.local 
 
 
/tool e-mail send to="admin@host.com" subject=([/Router_01]." backup") 
file=email.backup;
:log info "Backup e-mail sent."; } 
теперь добавим эту команду в scheduler чтобы она выполнялась автоматически.
 
/system scheduler 
add comment="System backup" disabled=no interval=1d name="e-mail_backup" \
on-event=e_mail_backup start-date=jan/01/1970 start-time=00:00:00 
Все теперь каждый день в 00:00:00 вам на почту будет 
приходить бекап системных настроек с роутера микротик.
 
Удачи вам. 
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.
 


понедельник, 20 февраля 2012 г.

Простой скрипт для бекапа файлов на удаленный FTP серер

Возникла задача периодически сливать файлы на удаленный ftp сервер. Наиболее быстрый способ решить эту задачу - написать его скрипт на Perl
Вот весь код:


#!/usr/bin/perl -w
  my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime time; #получаем дату.(я в скрипте использую только $mday $mon и $year так как более подробная информация мне не нужна. Вы де можете использовать необходимое количество нужных переменных.)

system("rm -rf /voip/wav.*");  # Очищаем временную папку.
system("mv /voip/*.wav /voip/wav/"); # Перемешаем все необходимые файлы во временную папку.
system("tar czf /voip/wav\_$year\_$mon\_$mday\.tar.gz /voip/wav/*"); # архивируем временную папку. Имя архива в формате имя_год_месяц_день-создания.tar.gz

    $username="ftpuser"; #задаем ftpusername
    $password="ftppassword";# задаем ftppassword
    $filename="/voip/wav\_$year\_$mon\_$mday\.tar.gz"; # задаем имя архива который будем копировать по ftp
    use Net::FTP; # подключаем модуль Net::FTP
    $ftp = Net::FTP->new("ftp.server.loocal") or die "Couldn't connect\n"; # подключаемся к серверу.
    $ftp->login($username, $password) or die "Couldn't change login\n"; # Проверка логина/пароля
    $ftp->binary or die "Couldn't get binary";  # включаем режим передачи бинарных файлов.
    $ftp->put($filename) or die "Can't connect: $@\n"; # Заливаем файл на сервер.

Вот и все осталось только прописать запуск этого скрипта в кроне в нужное для нас время. С ие забыть дать права на запуск
chmod 7XX  /путь/к/файлу/скрипт.pl
Удачи вам в работе.
Если есть вопросы до пишите в каментах. По возможности постараюсь помочь.

пятница, 17 февраля 2012 г.

Router OS 5.13, 5.12, 5.6

14.02.2012 вышли в свет обновления для RouterOS версий 5.13, 5.12, 5.6.  Ничего фундаментального в них не поменялось но кое что все-таки исправили. Вот список изменений.
Для версии 5.12


Консоль - команду passwd теперь можно использовать в скриптах и API.
Winbox - реорганизована работа с консолью.
SSH - исправлена проблема с psftp.
Добавлен SMB server.
Исправлена ошибка с ovpn-client.
Исправлена ошибка с ipv6 neighbor discovery.
Консоль  исправлены минорные ошибки.
Консоль - добавлена поддержка compact export.

Hotspot - Добавлен редирект при статусе http 302;
Wi-Fi -  Добавлен дефолтный конфиг для карт  R5SHPn.
PPP - Исправлена проблема с  remote-ipv6-pool.
Winbox, Webfig - Добавлена сортировка интерфейсов.
Добавлен QuickSet для RBSXT, RB411, RB711.Добавдена поддержка LTE модемов.

Для версии 5.13

Firewall - to-address теперь можно задать как сеть.маска.
Traffic-generator - исправлена проблема с падениями на многоядерных системах.
SMB - Исправлено и улучшено.
Dhcp client - Исправлено и улучшено.
Quickset -  страна & channel-width не зависят друг от друга.
Quickset - Добавленна поддержка PPPOE соединений через Wi-Fi интерфейс.
Bridge -Испраслена проблема с arp reply-only
Webfig -
Webfig - отображается окно ввода логина\пароля  при неудачном авто логине;

 Для версии 5.6
BGP -  Допущены параллельные операции согласно RFC4761 "l2vpn" and
draft-ietf-l2vpn-signaling "l2vpn-cisco" BGP VPLS.
 Консоль - команда ":resolve" возвращает IPv6 адрес для хостов которые используют IPv.6.
SNMP - Добавлена поддержка UPS с отображением уровня заряда батареи.
Route -Исправлена проблема с SNMP трафиком.

Mikrotik RB751, RB751G, Mikrotik RB400L series, R5SHPN, OmniTIK UPA-5HnD. Новинки от копмании Mikrotik.

В январе этого года компания Mikrotik немного обновила свой модельный ряд о чем я писал ранее. В январе этого года появились на свет несколько новых устройств RouterBoard 751,RouterBoard 751G, серия RouterBoard 400L, 5 ггц карточка R5SHPN, и  OmniTIK UPA-5HnD. Давайте рассмотрим подробнее что же нового в этих устройствах.
Mikrotik RB751 - это компактный wireless SOHO AP Router в симпатичном белом корпусе с 5х100mbps и1 USB портами на борту и 802.11b/g/n WI-FI карточкой. Зная продукты компании микротик качество исполнения остается на высоте.
Mikrotik RB751G - тоже самое только с гигабитными портами.
Эти 2 RouterBoard являются прямым продолжением линейки RouterBoard 750 и 750G, которые отлично зарекомендовали себя в работе.
Mikrotik RB400L series это новая линейка RouterBoard вышедшая из серии RB400 которую немного урезали и упростили. Пока в этой серии только 4 устройства:
RB411L 
RB433L
RB433UAHL
RB433GL 
RouterBoard 411L и RouterBoard 433L не имеют com порта и питаются только через PoE.
RouterBoard 411L имеет  на борту слот MiniPCI.
RouterBoard 433GL имеет отдельный вход для питания, Гигабитный порт и 3 MiniPCI слота.
R5SHPN - Это новая супер мощная Wi-Fi 5GHz Карточка. Главной особенностью этой карточки помимо мощности в 800mW являются 9 светодиодов, которые покажут вам состояние подключения, качество сигнала и RX/TX,  
OmniTIK UPA-5HnD - всепогодная базовая станция 5GHz 802.11a/n. Наиболее оптимально работает с устройствами серии SXT. Имеет 5 10/100 Ethernet портов, PoE и 400mW 802.11a/n Wi-Fi адаптер. Благодаря поддержке технологии Nv2  TDMA суммарная пропускная способность выросла до 200mbps. Наличие USB порта и последней версии RoutrerOS подключить 3G модем теперь не составляет большого труда.
Более подробно эти девайсы я опишу когда они появятся на Украинском рынке. 
Удачи.

среда, 15 февраля 2012 г.

Mikrotik default IP

В связи с тем что поток вопросов о дефолтном IP на микротиках не прекращается напишу об этом целую статью.
1: Default IP для всех устройств компании Mikrotik 192.168.88.1
2: Если вы забыли какой IP установили на Микротике - Winbox найдет этот микротик по маку и зайдет не него без проблем. Главное чтобы вы были в одной сети.
3: Если вы не помните Vlan и IP см п2.
4: Если вы не помните Vlan и IP и в разных логических сетях или микротик подключен по радио то на него можно зайти через Mac telnet с другого устройства компании Mikrotik.
5: Ничего из вышеперечисленного не помогло - это не повод ресетить девайс - можно подключится через com порт но это не для всех девайсов.

к стати default login/password на Mikrotik это admin/admin

понедельник, 13 февраля 2012 г.

Mikrotik RB1100AHx2

Вышел новый Mikrotik RB1100AHx2.  Это достойное продолжение линейки аппаратных маршрутизаторов Mikrotik и впервые в линейке с двух ядерным процессором. Более подробные характеристики RB1100AHx2

  • Процессор                       P2020 / 1066MHz.
  • RAM                                2GB
  • Архитектура                    PPC
  • Количество портов GB 13
  • Карты памяти                1 microSD
  • PoE                                  10-28V
  • Формат                           1U case: 44 x 176 x 442 mm, 1200g. Board only: 365g
  • Операционная система RouterOS
 По заявлениям производителя эта железяка может вытянуть до 1 000 000 pps. Будем на это надеяться. Как только данный девай попадет мне в руки сразу отпишусь по проведенных тестах.

Альтернативя Microsoft Exchange для Linux.

При переводе офиса с Windows на Linux перед системным администратором возникает огромное количество проблем. Основная проблема - это как подобрать софт не уступающий Windows аналогам. Процесс этот обычно трудный длительный и часто упирается в такой момент - когда нет возможности заменить весь софт организации одновременно и всем не запуская параллельно 2 серверные площадки.
После долгого и мучительного изучения free  приложений для замены Mikrosoft Exchange я нашел очень интересное решение  Synovel Collabsuite - Linux Mail Server with Calendaring and IM. Хороший сервис - незаслуженно обделенный вниманием росийских админов судя по количеству русскоязычных отзывов.
И так что же представляет из себя  Synovel Collabsuite Server? Это Linux based Email server, календарь сервер (протокол Caldav), сервер контактов и сервер мгновенный сообщений.
Помимо сервера к этому всему еще идет и мультиплатформенный десктопный клиент Spicebird на основе Thunderburd.




 Подробнее о возможностях: 
  • Email server - SMTP, POP3 and IMAP
  • Webmail - Ajax, re-branding support
  • Calendar server - Caldav protocol
  • Instant messaging server - Jabber protocol
  • Anti-virus and Anti-spam
  • Archival system with robust search
  • Admin panel - Web based, simplified and intuitive
  • Active Directory® integration
  • CentOS® Directory Server integration
  • Automatic data backups
  • Server monitoring, statistics
И еще много других интересных вкусностей и полезностей позволяющий рассматривать  Synovel Collabsuite как серьезную альтернативу Microsoft Exchange. Для больший компаний и гос предприятий существуем комерческая версия ноторя отличается немного более расширенным функционалом и поддержкой. Но для моих задач мне вполне хватает synovel. Да и вопросов по его установке небыло - все подробно описано в мануале да ит работает нормально из коробки - сразу видно что для людей делалось. 
Стоит отметить реально удобную панель администратора. Я сначла из консоли всем рулил по привычке, но сейчас уже через веб удобней стало. Так быстрее и проще.
Вот с помощью такого нехитрого инструмента можно отправить в АД Microsoft Exchange и установить Linux bases  систему всего за одни выходные. А клиентов перевести это дело техники и времени так как Synoven Spacebird  это кроссплатформенное решение.
Удачи в реализации!